Visual Studio setup-projekt kräver .NET 3.5

Ett problem som jag nyligen stötte på när jag skapade en installation, för ett .NET 2.0 projekt, var att det trots allt krävde .NET 3.5 vid installation. I min enfald trodde jag att edet enkelt åtgärdades genom att välja bort den som “prerequisit” för installationen.

Nej… SÃ¥ var inte fallet då “Launch Conditions” för MSI paketet har .NET 3.5 valt som standard. Det fixas enkelt sÃ¥ här:

1. Klicka höger och välj “View” sedan “Launch Conditions” på setup-projektet.

2. Klicka höger och välj egenskaper på “.NET Framework”.

3. Ändra nu vilken .NET version som installern ska kräva under “Version”.